Pre-requirements for installing DeskAlerts

Back to contents

Previous section

Next section

To deploy the DeskAlerts application, please ensure that you meet the following minimum hardware and software requirements:

For the DeskAlerts servers:

  • Windows Server 2008/2012 (R2 editions are supported)
  • Microsoft IIS 7.5 or higher (ASP must be enabled) – for Web Server
  • Microsoft SQL Server 2008 or higher – for Database Server (Express versions are supported)
  • Microsoft .NET Framework 4.5 or higher.

Exact hardware requirements for DeskAlerts servers depend on the total number of DeskAlerts users and can be found here


Note: Prior to installing DeskAlerts on a web server, make sure that required features of IIS are enabled through Server Manager. On Windows Server 2012 and above, the ASP, ASP.NET 3.5 and ASP.NET 4.5 features should be turned on. On Windows Server 2008, only the ASP and ASP.NET features are required.

Notice for Windows Server 2008 users: In Windows Server 2008, ASP.NET 4.5 can’t be installed and registered through the Server Manager. Instead, you should get the installer from Microsoft website, install it manually, then register the component in IIS using “aspnet_regiis -i” command, as described here.


For the DeskAlerts client:

  • Windows 7 (SP1)/ 8.1 / 10 or Mac with OSX 10.7.4 or higher
  • Internet Explorer 11 for Windows-based machines
  • 256MB RAM at least
  • For DeskAlerts v9.1 clients, .NET Framework 4.6.2 and Visual C++ Redistributable packages (2013) should be installed on Windows workstations.

You can see detailed system requirements and bandwidth consumption info on the special page or look in our FAQ.

Note: don’t forget to set “case insensitive” parameter as default sorting value when installing MS SQL Server – for optimal performance of Search function on Users, Groups, etc.

Read MS SQL installation and configuration Manual available in .pdf format.

Previous section

Next section